Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme

TEMA:

Nivel de Agua con Arduino y MPX5010 Ayuda 3 años 9 meses antes #218

Eso es
Te dejo aqui el codigo que hicimos al principio con millis
Adjuntos:

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Nivel de Agua con Arduino y MPX5010 Ayuda 3 años 9 meses antes #219

Vale, el problema es que antes tomabas como referencia las dos señales y ahora al tener diferentes niveles los tanques, los flag te hacen cosas que no quieres y se vuelve loco el arduino.
Vas tener que plafinicar un poco las cosas, y yo empezaria a sacar cosas que no tienes claro como funcionan, por ejemplo
  if ( flagTanque1, flagcontrolsonido)

Tu tienes claro como funciona este comando? que es un or de las dos variables? deberian ser un Or? o deberia tener una peso sobre la otra?

Tienes que depurar un poco el codigo y pensar un poco mas las cosas.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Última Edición: por Jose Luis.

Nivel de Agua con Arduino y MPX5010 Ayuda 3 años 9 meses antes #220

Ese comando ya lo probé como tu me dijiste y hace los mismo, y es cierto el arduino se vuelve un poco loco.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Nivel de Agua con Arduino y MPX5010 Ayuda 3 años 9 meses antes #221

Yo es que no acabo de verlo, pero no dudo que funcione perfectamente.
Habra que buscar otra cosa entonces.
:)

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Nivel de Agua con Arduino y MPX5010 Ayuda 3 años 9 meses antes #222

Pues, voy a intentar replantearlo de otra manera, haber si soy capaz, lo que no entiendo es, que si quito del código la entrada A3 y todo lo que conlleva funciona perfectamente, en cuanto duplicamos el código ya el arduino se queda colgado.
Y tampoco lo veo tan complicado para que arduino se quede colgado.

Buenos voy a pensar algo antes de ir a cama

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Nivel de Agua con Arduino y MPX5010 Ayuda 3 años 9 meses antes #223

No se queda colgado, parece que hace cosas raras por culpa de los flags que generan las dos entradas, una te esta interferiendo sobre la otra,
Por eso parece que hace cosas raras, pero no, el problema esta en cuando activas y cuando desactivas los flags ( y cuando lo haces).
Por eso eso hacia himcapie en los comandos que no estuvieras seguro como funcionaban.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Tiempo de carga de la página: 0.142 segundos
Gracias a Foro Kunena